jwzlyrics auto-updates

Hey, if you're running jwzlyrics 1.7 then I think that "Check for Updates" will now tell you that 1.8 is available. However, I also think that when you try to install it via the built-in updater, it will tell you "the update is improperly signed", because the key inside the 1.7 bundle is bogus.

So, please go download 1.8 and install that, because I think that once I release 1.9, maybe later today, the updater should work. Let me know how it goes!

(Alternately, if you're feeling adventurous: replace the jwzlyrics.app/Contents/Resources/sparkle_dsa_pub.pem file in the 1.7 bundle with the copy of that file from the 1.8 bundle, and then when you run that 1.7 app, it should be able to upgrade itself to 1.8. If you feel like trying that, I'd be curious to know if that trick works on MacOS versions 10.7, 10.8 and 10.9, since I only have 10.8.)

Previously, previously.

Tags: , , ,

4 Responses:

  1. Faried Nawaz says:

    Copying 1.8's pem file into 1.7's app directory worked for me (10.9).

  2. Faried: Cool, thanks!

  3. Liam says:

    On MacOS 10.9 I copied the .pem from 1.9 to 1.7 (as 1.8 isn't there anymore).
    1.7 runs, asks me if I want to check for updates automatically.
    I do the Check for Updates, and I am offered 1.9. Installs and relaunches About shows Version 1.9 (1.9)

    Cheers, Liam

  4. TimeDoctor says:

    Update worked for me :)